TS: My CEL10 won't ignite

If your Eccotemp CE-L10 will not ignite, please review the following troubleshooting guide.

1.Check your propane tank to determine if you are out of gas and check your batteries to see if they are properly installed. If your batteries are not new, try another set. When checking your batteries, if you encounter corrosion, gently clean the connections with a wire brush and install a fresh set. Be careful when doing this as battery acid is extremely harmful and poisonous.

2.Disconnect the incoming water line. There is a screen immediately inside of the incoming water pipe that may have clogged over time and is reducing the water flow and water pressure.

3.After following these steps, test to see if the water heater is working.

4.If possible, disconnect the plumbing from the outgoing water connection and try to operate the water heater to determine if your plumbing is the issue.

You need to have a minimum of 20 pounds per square inch of water pressure to activate and sustain operation of the CE-L10 water heater. If you cannot achieve and maintain adequate water pressure, your water heater will function erratically or not at all. If you have low pressure that is near adequate, please follow the link below to access instructions on increasing your CE-L10's sensitivity to water pressure:

https://eccotemp.zendesk.com/attachments/token/vkovnpzfcoips4n/?name=Pressure+Adjustment+Guide.pdf

If those steps did not help, turn off your gas supply. Take the cover off by removing the 4 screws at top and 2 on the bottom and the knobs pull off. Disconnect and reconnect all wire connections to ensure that everything is properly seated. To test your electrical system, please click on the link below:

https://eccotemp.zendesk.com/attachments/token/rshnzog2vwt9x9e/?name=TestingTheElectricalSystem.pdf

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.